HCIE学习之路1:GRE隧道实验

这两天自己谋划着打算写一个新的分类:网络。温故而知新,回归老本行,同样也分享一些常用的网络知识,以便共同进步。

这儿用到的软件ensp,目前已经停止更新了,有需要的同学可以私信我。

第一讲先复习GRE隧道,GRE隧道是一种基于通用路由封装协议(GRE)的隧道技术,可用于在不同的网络之间传输数据包。创建GRE隧道需要两个路由器或设备来进行配置。

以下是一些基本步骤来创建一个GRE隧道:

  1. 确定两个路由器的IP地址和网络拓扑结构。
  2. 在两个路由器上启用GRE协议。
  3. 配置隧道端点IP地址,这是GRE隧道的源和目的地地址。
  4. 配置路由器的接口,以便将数据包从本地网络传输到GRE隧道。
  5. 配置路由器的路由表,以便将数据包从GRE隧道传输到目标网络。

路由器和交换机中实验ip命令一般根据设备编号设置,比如:r1至r2的链路一般是12.0.0.0,r1的ospf区域id是1.1.1.1,以此类推。一般接口配置为同一类型设备是同一端口同一类型配置,例如。边界路由器,内部路由器,ABR和ASBR。该实例拓扑如下图所示,

由路由器划AR1和AR3划分192.168.10.x和192.168.20.x两个网段,写入了接口dhcp让PC自动获取IP。AR1AR3三个区域写入OSPF,默认分别为1.1.1.1,3.3.3.3,AR2配置回环口loopback1,ip:2.2.2.2。AR1至AR3需要建立GRE通道则需要配置隧道端口。其他步骤需要配置静态路由和配置端口地址,加入ACL2000规则,确保网络设备全通,主要地址和端口已在图中标出。

notepad敲白板,AR1配置:

sys
sysname r1
ip route-static 0.0.0.0 0.0.0.0 12.0.0.2
#
acl number 2000
rule 1 permit source 192.168.10.0 0.0.0.255
#
interface GigabitEthernet0/0/0
ip address 192.168.10.254 255.255.255.0
dhcp select interface
#
interface GigabitEthernet0/0/1
ip address 12.0.0.1 255.255.255.0
nat outbound 2000
#
interface Tunnel0/0/0
ip address 192.168.13.1 255.255.255.0
tunnel-protocol gre
source 12.0.0.1
destination 23.0.0.3
#
ospf 1 router-id 1.1.1.1
area 0.0.0.0
network 192.168.10.0 0.0.0.255
network 192.168.13.0 0.0.0.255
#

AR2配置:

sys

sysname r2

#
interface GigabitEthernet0/0/0
ip address 12.0.0.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 23.0.0.2 255.255.255.0
#
interface LoopBack1
ip address 2.2.2.2 255.255.255.255
#

AR3配置:

sys
sysname r3
ip route-static 0.0.0.0 0.0.0.0 23.0.0.2
#
acl number 2000
rule 1 permit source 192.168.20.0 0.0.0.255
#
interface GigabitEthernet0/0/0
ip address 192.168.20.254 255.255.255.0
dhcp select interface
#
interface GigabitEthernet0/0/1
ip address 23.0.0.3 255.255.255.0
nat outbound 2000
#
interface Tunnel0/0/0
ip address 192.168.23.1 255.255.255.0
tunnel-protocol gre
source 23.0.0.
3
destination 12.0.0.1
#
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 192.168.20.0 0.0.0.255
network 192.168.23.0 0.0.0.255
#

这样实现了PC1到PC3的互访。

发表回复